Jump to content
Security Installer Community

G2 44+ PSU fault


Driller

Recommended Posts

Hello everyone,

 

Hope you're getting along ok in these difficult times.

 

I've been getting what seems to me to be an odd PSU fault for the last week (G244 with 2 x powered RIOs).  In the unset state the keypad will randomly go into the alert state with the dreaded beep. On inputing the master code the screen shows the following fault:

 

AC Fail PSU 103

 

which I assumed to be the PSU on the second RIO unit (103=3rd PSU after main panel?) but now not so sure.  On opening all 3 panels all would appear to be fine inside with the red LED in the RIO units flashing at the correct rate.  

 

I installed the main panel back in 2011 which has been flawless and the 2 RIOs early this year and they've both been fine too.

 

Any ideas from the Galaxy experts here?

 

Many thanks,

Richard

Edited by Driller
Link to comment
Share on other sites

6 minutes ago, Driller said:

Hello everyone,

 

Hope you're getting along ok in these difficult times.

 

I've been getting what seems to me to be an odd PSU fault for the last week (G244 with 2 x powered RIOs).  In the unset state the keypad will randomly go into the alert state with the dreaded beep. On inputing the master code the screen shows the following fault:

 

AC Fail PSU 103

 

which I assumed to be the PSU on the second RIO unit (103=3rd PSU after main panel?) but now not so sure.  On opening all 3 panels all would appear to be fine inside with the red LED in the RIO units flashing at the correct rate.  

 

I installed the main panel back in 2011 which has been flawless and the 2 RIOs early this year and they've both been fine too.

 

Any ideas from the Galaxy experts here?

 

Many thanks,

Richard

I am definitely not an expert lol

 

But seen these throw up a fault , how have you wired up the power lines ? From the panel what did you wire to the PSU rio

Just now, MrHappy said:

have you considered buying a dog ?

Have you got a dog?

Link to comment
Share on other sites

9 hours ago, Driller said:

Thanks for the suggestions (and Mr Happy's inimitable input ;-)). I'll be able to get a tester on it tomorrow and see what it says. Cheers Nova for the heads up on the cards. 

 

Possibly C4 / C7

www.nova-security.co.uk

www.nsiapproved.co.uk

No PMs please unless i know you or you are using this board with your proper name.

Link to comment
Share on other sites

  • 10 months later...
34 minutes ago, Driller said:

Forgot about this. In the end the bloody thing just started behaving itself, guess the multimeter gave it a scare 

 

I've been waiting with baited breath for the results....

Mr😀 Veritas God

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.