Jump to content
Security Installer Community

Texecom Premier Elite issues


Recommended Posts

I decided to upgrade my old Veritas alarm I installed several years ago for a new Texecom Premer elite so I can install some additional devices in the future 

 

 

I've installed the NEW controller, exterior siren and Remote keypad onto tested existing wiring, i've also installed two door contacts and two PIR's

 

the issue I'm having once I powered it up and loaded the software as instructed, its saying there's system alerts then a rolling numbers of tamper faults from 001 through to 008, I've checked the obvious place for a fault on the exterior siren (for good measure I've adjusted the back plate screw and tamper screw on the internal cover all seem good), now because I've open the siren its showing exterior bell tamper that won't clear also the RKP says "call the engineer for a service" I can't find in the installation instructions how to reset these messages

 

I've made sure the JP7 is on the centre and right pins all covers are on and I'm total baffled 

 

 

any help would be mightily appreciated  

 

 

Regards

 

 

Lee

Link to comment
Share on other sites

Hi James

 

they're wired as EOL only two PIR on existing wiring, I'm expanding the system with three wireless capture PIR I bought with panel

 

other two wired zones are magnetic door contacts 

 

 

lee 

Link to comment
Share on other sites

Hi James 

 

the remote key pad won't let me go into any settings or diagnostics it continually flashes "call the engineer for service"  and fault tamper 001 - 008

 

 

I've powered it down for today and going to take another look in morning, can't find anywhere in the instructions about clearing messages  

 

 

lee

Link to comment
Share on other sites

1 hour ago, Leebut said:

Hi James 

 

the remote key pad won't let me go into any settings or diagnostics it continually flashes "call the engineer for service"  and fault tamper 001 - 008

 

 

I've powered it down for today and going to take another look in morning, can't find anywhere in the instructions about clearing messages  

 

 

lee

So you need to put in the engineer code?

Link to comment
Share on other sites

You don't say what model Elite

Veritas is a double pole only panel so you have put resistors in detectors?

If the keypad is unresponsive to the code then you have an issue on the network line, check panel LED's adjacent network for faults or for double address.

Link to comment
Share on other sites

12 hours ago, sixwheeledbeast said:

You don't say what model Elite

Veritas is a double pole only panel so you have put resistors in detectors?

If the keypad is unresponsive to the code then you have an issue on the network line, check panel LED's adjacent network for faults or for double address.

I've installed a Premier Elite 64W LS

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.