Jump to content
Security Installer Community
RevolvingSteve

Galaxy Flex 20 with RF & RIO

Recommended Posts

Some free time again so back onto the Alarm.

 

I seem to have everything working on the main panel now and have been setting the alarm for a week or so, no issue!

 

Now I want to add the RIO expander to put the extra door contacts in. I have fitted it and wired the RIO back to the Lfex on the same terminals as the KeyPad, I have a flashing green light on the RIO now, but cannot see anything that it has recognised the RIO or any extra zones in the zones menu?

 

Any ideas?

Share this post


Link to post
Share on other sites

List zones showing in menu

 

When you added the Rio did you address it enter engineer mode then exit , I assume adding a Rio hasn't changed on the flex then when exiting it says new mod added 

Share this post


Link to post
Share on other sites

Which firmware version flex? I seem to remember some issues trying to mix fx20 with portal and RIO. Never had the problem on fx50 or fx100.

Share this post


Link to post
Share on other sites
12 hours ago, al-yeti said:

List zones showing in menu

 

When you added the Rio did you address it enter engineer mode then exit , I assume adding a Rio hasn't changed on the flex then when exiting it says new mod added 

 

Yep, I didn't the enter/exit Eng mode, didn't show anything new (was 12, now 12.. I think from memory)

Share this post


Link to post
Share on other sites

Did you address correctly 

Share this post


Link to post
Share on other sites

 

On 20/02/2019 at 13:08, al-yeti said:

Did you address correctly 

 

I have the addresses set as follows:

 

KeyProx 1 : 0

KeyProx 2 : 1

RF Module : 5 (no idea why I set it to 5?)

RIO Unit : 3

 

As always, thanks for the time and help.

Share this post


Link to post
Share on other sites
1 minute ago, Nova-Security said:

Not sure on the flex but 12 zones on the panel ? add an RF module doesn't that take 8 up making 20 and your panel is a flex 20 

 

I thought the RF Zones were not included in the '20'? But I'm not 100%

Share this post


Link to post
Share on other sites
1 hour ago, Nova-Security said:

Not sure on the flex but 12 zones on the panel ? add an RF module doesn't that take 8 up making 20 and your panel is a flex 20 

I thought you could do RF on all the zones like the g2 , your thinking dimension?

Share this post


Link to post
Share on other sites
1 hour ago, Nova-Security said:

so what are you RF zones numbers 1021 to 1028 ?

 

I can see these zones in the display zones menu (Menu 21):

 

1001 > 1004

1011 > 1018

1021 > 1028

 

I know 1001 through 1018 are the Main board, can't see if the 1021> Zones are the RF or the RIO, I expected the address of the RIO & RF to dictate the zones like this:

 

RF Module (Address 5) : 105x

RIO Unit (Address 3) : 103x

 

But its more likely I have misunderstood the manual.

Edited by RevolvingSteve

Share this post


Link to post
Share on other sites

OK, so further info:

 

If I use menu 52.1 (Program Zones > Zones) I see:

1001 > 1004

1011 > 1018

1021 > 1028

 

If I go into 52.2 (Program Zones > RF Zones)  I see:

1021 > 1028

 

Not sure if there is a better menu to view this.

Share this post


Link to post
Share on other sites

The RF portal can have up to three virtual Rio addresses. They are not the same as the physical bus address of the portal.  The virtual Rio addresses are in menu 56.60.1

 

The last time I looked at this, the Flex would not allow the portal to coexist with the Rio on an fx20 in the way that was allowed on the older g2-20 panels. The panel responded differently depending on which module was added first (Rio or portal).

 

IfI get a minute, I will test that this is still the case at the latest Flex version 3.50.

Share this post


Link to post
Share on other sites
1 hour ago, GalaxyGuy said:

 

The last time I looked at this, the Flex would not allow the portal to coexist with the Rio on an fx20 in the way that was allowed on the older g2-20 panels. The panel responded differently depending on which module was added first (Rio or portal).

 

Wonder why they called it flex , not very flexible then 

Share this post


Link to post
Share on other sites
5 hours ago, GalaxyGuy said:

The RF portal can have up to three virtual Rio addresses. They are not the same as the physical bus address of the portal.  The virtual Rio addresses are in menu 56.60.1

 

The last time I looked at this, the Flex would not allow the portal to coexist with the Rio on an fx20 in the way that was allowed on the older g2-20 panels. The panel responded differently depending on which module was added first (Rio or portal).

 

IfI get a minute, I will test that this is still the case at the latest Flex version 3.50.

 

No surprise I have managed to end up with the complicated version LOL

 

OK, very grateful if you do get time. I don't actually need the RF portal yet (although I will) so is there a way to remove the RF Portal to allow the RIO to be picked up whilst sorting out if there is a solution?

3 hours ago, al-yeti said:

Wonder why they called it flex , not very flexible then 

 

Agreed!

Share this post


Link to post
Share on other sites

Just remove the portal and scan devices in menu 72 - * to delete. Then scan again to find the RIO.

 

I think the intent is to stop zone expansion beyond the 20 zone limit of the panel, but you should be able to expand to 20 zones max and have any of the 20 hardwired or wireless. It seems that this may not be an option with the FX20 and you can only have 12 hardwired and a possible 20 wireless. If you upgrade to an FX50 or FX100, you can have a number of RIO's fitted.

 

As I said, I thought that this was a bug in the early Flex and I never went back to see if it was fixed in the newer models, as I only use the FX100+ now anyway.

Share this post


Link to post
Share on other sites
8 hours ago, GalaxyGuy said:

Just remove the portal and scan devices in menu 72 - * to delete. Then scan again to find the RIO.

Is then, 72, then *? doesn't seem to do anything.

 

8 hours ago, GalaxyGuy said:

I think the intent is to stop zone expansion beyond the 20 zone limit of the panel, but you should be able to expand to 20 zones max and have any of the 20 hardwired or wireless. It seems that this may not be an option with the FX20 and you can only have 12 hardwired and a possible 20 wireless. If you upgrade to an FX50 or FX100, you can have a number of RIO's fitted.

 

Does the FX50 fit in the same housing?

 

8 hours ago, GalaxyGuy said:

As I said, I thought that this was a bug in the early Flex and I never went back to see if it was fixed in the newer models, as I only use the FX100+ now anyway.

 

Is it just the zone qty that's different between the models?

Share this post


Link to post
Share on other sites
59 minutes ago, RevolvingSteve said:

Is then, 72, then *? doesn't seem to do anything.

 

The process is:

  1. Start the Auto-learn mode in menu 72.

  2. Remove the device from the data bus (for example disconnect the module).

  3. Exit from the Auto-learn mode and confirm the address of the device removed (using *).

  4. Enter Auto-learn mode once more.

 

59 minutes ago, RevolvingSteve said:

 

Does the FX50 fit in the same housing?

 

 

Is it just the zone qty that's different between the models?

 

Yes, the boards across the range are the same form. Only different between the metal case and plastic case boards.

 

The Flex+ supports grade 3.  The 50 and 100 series panels support more users, zones, outputs, bigger event and access logs, schedules, keypads and links.

 

 

 

Share this post


Link to post
Share on other sites

Okay, checked this out on the Flex with a RIO.  So what you need to do is configure the virtual RIO in the RF portal so that it doesn't take any addresses up.  Ie. No virtual RIO enabled. Then you can configure any of the 20 hardwired zones as either wireless or hardwired.  The easiest way to do this is to:

 

1. Enter engineering mode and remove both portal and rio from the system.

2. Exit engineering mode and remove the devices from the config when prompted.

3. Set the RIO address to 2 and add back to the bus.

4. Enter eng mode and menu 72 to detect the device.

5. Add the portal and then menu 72 to detect it.

 

Now the portal should show on its bus, but with no virtual RIO's addressed (menu 51.60.1 shows the virtual RIO - note my typo earlier when I said it was 56).

 

If you want to do this without removing devices, you need to use 51.60.1 to diable the virtual rio, then the hard wired RIO can be enumerated onto the bus.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
34 minutes ago, GalaxyGuy said:

Okay, checked this out on the Flex with a RIO.  So what you need to do is configure the virtual RIO in the RF portal so that it doesn't take any addresses up.  Ie. No virtual RIO enabled. Then you can configure any of the 20 hardwired zones as either wireless or hardwired.  The easiest way to do this is to:

 

1. Enter engineering mode and remove both portal and rio from the system.

2. Exit engineering mode and remove the devices from the config when prompted.

3. Set the RIO address to 2 and add back to the bus.

4. Enter eng mode and menu 72 to detect the device.

5. Add the portal and then menu 72 to detect it.

 

Now the portal should show on its bus, but with no virtual RIO's addressed (menu 51.60.1 shows the virtual RIO - note my typo earlier when I said it was 56).

 

If you want to do this without removing devices, you need to use 51.60.1 to diable the virtual rio, then the hard wired RIO can be enumerated onto the bus.

 

 

As simple as that !

Share this post


Link to post
Share on other sites
On 27/02/2019 at 23:45, GalaxyGuy said:

Okay, checked this out on the Flex with a RIO.  So what you need to do is configure the virtual RIO in the RF portal so that it doesn't take any addresses up.  Ie. No virtual RIO enabled. Then you can configure any of the 20 hardwired zones as either wireless or hardwired.  The easiest way to do this is to:

 

1. Enter engineering mode and remove both portal and rio from the system.

2. Exit engineering mode and remove the devices from the config when prompted.

3. Set the RIO address to 2 and add back to the bus.

4. Enter eng mode and menu 72 to detect the device.

5. Add the portal and then menu 72 to detect it.

 

Now the portal should show on its bus, but with no virtual RIO's addressed (menu 51.60.1 shows the virtual RIO - note my typo earlier when I said it was 56).

 

If you want to do this without removing devices, you need to use 51.60.1 to diable the virtual rio, then the hard wired RIO can be enumerated onto the bus.

 

 

I had exactly the same issue.  Thank you so much for sharing. Now I just need to work out how to use the Ethernet module to connect to the app...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.