Jump to content
Security Installer Community
Sign in to follow this  
john01

john

Recommended Posts

 

Advice please. I was changing the battery on the Veritas 8. When I pulled out the earth lead from the old battery, The alarm went off (mains power was off). I put power back on and reset alarm to kill the external siren. I then noticed that the black and red wire wound together at the bottom left of picture was loose. Don't know whether it never was in a terminal or i knocked it out when i pulled the battery wire. Does anyone know where this wire goes please?

Thanks in advance

john

 

 

Image preview

Share this post


Link to post
Share on other sites

Earth lead?

 

Where does the red and black come from?  You have nothing it the strobe terminal but I cant imagine both red and black would come from there.

Share this post


Link to post
Share on other sites

Yes Thanks Peter, I saw that empty terminal and did wonder but the terminal screw is very undone as if there never was anything in there!

Share this post


Link to post
Share on other sites

I assume by earth you actually mean the black negative battery lead.

Battery lead terminals on a Veritas are marked as BATT + and -

I can't see your image so not sure if you are talking about something else.

Share this post


Link to post
Share on other sites

Yes sorry I meant to say negative on the battery.

Can you see this picture?

Image preview

Share this post


Link to post
Share on other sites
40 minutes ago, PeterJames said:

 

 

Where does the red and black come from?  

 

Share this post


Link to post
Share on other sites

Not sure why the picture has gone it was a red and black wire twisted together lose in the panel.

 

I would put everything back together a bit of tape over the wire and see if everything works, walk test bell test ect 

Share this post


Link to post
Share on other sites
Just now, sixwheeledbeast said:

I can't for whatever reason.

You can attach images in the post if you need

He did but its gone, I had trouble the other day with pics  maybe James is doing something with the Server 

Share this post


Link to post
Share on other sites

Thanks for your advice. The alarm is working ok at the moment. So hopefully it's nothing too important. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.