Jump to content
Security Installer Community

Honeywell g2-12. Additional code required?


Recommended Posts

Hi. I realise before posting this question that I'm going to be accused of not being trained, or a professional and taking work from hard working alarm installers 😁 but here goes anyway. My story. I work from home on high value items so have a monitored police response alarm serviced by a local alarm company. (So I am supporting the industry) 

 

I wanted to alarm my detached garage some distance from the house so looked at DIY alarm kits. Seemed expensive for a very basic alarm. For less money I bought a honeywell g2 and mk7 keypad as this is a cutdown version of what I have in the main house. I liked the idea of only having to remember how to use one style of keypad and the prox tags are useful. All installed easily once I had worked out how to disable phone line fault (it's a stand alone system). Worked my way through programming without any problems. Simple system mag contacts on two main front doors and a key lock on pedestrian door that sets and unsets system if used to keep it simple.

 

My problem is probably simple or could be a panel fault I'm not sure. If I leave system set or unset for a couple of hours any code entered just gives the message "additional code required" I can clear this by removing power from panel including battery and then powering up again. All is well until later and then I get the same message and have to power down again to gain any access with any code or prox tag prox. 

 

Would appreciate any suggestions.

 

Link to post
Share on other sites
21 minutes ago, SteveB72 said:

Hi. I realise before posting this question that I'm going to be accused of not being trained, or a professional and taking work from hard working alarm installers 😁 but here goes anyway. My story. I work from home on high value items so have a monitored police response alarm serviced by a local alarm company. (So I am supporting the industry) 

 

I wanted to alarm my detached garage some distance from the house so looked at DIY alarm kits. Seemed expensive for a very basic alarm. For less money I bought a honeywell g2 and mk7 keypad as this is a cutdown version of what I have in the main house. I liked the idea of only having to remember how to use one style of keypad and the prox tags are useful. All installed easily once I had worked out how to disable phone line fault (it's a stand alone system). Worked my way through programming without any problems. Simple system mag contacts on two main front doors and a key lock on pedestrian door that sets and unsets system if used to keep it simple.

 

My problem is probably simple or could be a panel fault I'm not sure. If I leave system set or unset for a couple of hours any code entered just gives the message "additional code required" I can clear this by removing power from panel including battery and then powering up again. All is well until later and then I get the same message and have to power down again to gain any access with any code or prox tag prox. 

 

Would appreciate any suggestions.

 

Are you sure you don't have a fault ? And your missing it 

As above logs might show something, did you buy from eBay used panel?

Link to post
Share on other sites

If I look at log once I'm back in it shows it was powered down and then that I logged back in. Was from eBay but a new boxed panel. Came with resistors etc and terminals had not been used.

Link to post
Share on other sites
32 minutes ago, SteveB72 said:

If I look at log once I'm back in it shows it was powered down and then that I logged back in. Was from eBay but a new boxed panel. Came with resistors etc and terminals had not been used.

So when it says additional code required , you putaster code in , does it not say fault? 

 

What key you pressing after enter code?

 

 

Link to post
Share on other sites
16 minutes ago, al-yeti said:

So when it says additional code required , you putaster code in , does it not say fault? 

 

What key you pressing after enter code?

 

 

No, no faults show. I enter code then press enter key.

Link to post
Share on other sites

Update that may help. I just tried my user code and got "additional code required" as usual when it's been left for a while. But last time I was in programming I added a # to beginning of default engineer code so it had access without L3 access from user. I can now gain acces when user code or manager code won't work with engineer code. Seems it must be a code problem but beyond me !

Link to post
Share on other sites
4 hours ago, SteveB72 said:

No, no faults show. I enter code then press enter key.

What happens if you press A instead of enter when problem.showing?

Link to post
Share on other sites
2 hours ago, james.wilson said:

is it old firmware? id also talk to who you bought it from they have to support it

No latest firmware. I am taking with supplier and he is being very helpful and seems knowable. He has got me to re enter the user, master and engineer code and fingers crossed it seems to have worked. Just leaving it alone for a while now. I will keep you all update. 

Link to post
Share on other sites

Issue solved. I'm still not entirely sure why the panel was unhappy but this sorted it out. I re entered 3 levels of pin (a user, a master and an engineer) while logged into system as that person. Bingo no more "additional code required"

 

In case anyone comes across this problem this is what I think happened. I am not sure but I think I may have ended up having 2 users set as master. Both user 23 and user 2. I now have users 1 & 2 set as users L2, user 23 set as master and 24 set as engineer and all is well.

 

Thank you all for trying to help yesterday, very much appreciated.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.