Jump to content
Security Installer Community
Logan

Euro meridian keypad not working

Recommended Posts

The euro meridian system i have installed has a problem. One of the keypads (address set to 01) stopped accepting pincodes or prox tags. But the display works fine. Shows all information that it normally would.   The other keypad says "device fail 201"  as its a keypad addressed to 1.    I try the keypad on another panel and has the same problem 

Share this post


Link to post
Share on other sites

I'm fairly certain the address at the first keypad should be 00 not 01.

(This may be the reason why you are getting device fail) - I may be wrong but worth a shot

 

 

Edited by aissecur

Share this post


Link to post
Share on other sites
35 minutes ago, aissecur said:

I'm fairly certain the address at the first keypad should be 00 not 01.

(This may be the reason why you are getting device fail) - I may be wrong but worth a shot

 

 

 There are two keypads one is the master keypad addressed 00.  And there is the additional keypad addressed 01

Share this post


Link to post
Share on other sites

or power down remove one of the keypads (address the connected one as 00) and power back up to see if it works (try this with both different keypads in an attempt to rule out a faulty keypad)

Edited by aissecur

Share this post


Link to post
Share on other sites
2 hours ago, james.wilson said:

As above you have confirmed the keypad address of the 2nd keypad if both addressed as 00 it would do this

They are addressed right. Just one day ot started giving a message saying "Device Fail 201" the display works fine  it even says "Device Fail 201"  however no codes or tags are accepted and gives a long error beeb.  Tryed to reboot the system. Keypad still doesn't work correctly 

Share this post


Link to post
Share on other sites

 

Share this post


Link to post
Share on other sites
5 hours ago, james.wilson said:

I'd try addressing as 02 and disabling 01 in assign keypads 

Still no luck. I even tryed on a different panel and it still didn't work

Share this post


Link to post
Share on other sites

Do you know a good place to get one of these keypads. I just want to get a used one but couldn't find one on the internet as i dont want a new one as it costs to much i cant afford it 

Share this post


Link to post
Share on other sites
1 hour ago, james.wilson said:

no they are long obsolete I would think any companies that have them will keep hold of them for repair stock

I saw a euro 12 with the keypad on Security Warehouse https://www.securitywarehouse.co.uk/catalog/intruder-alarm-c-36/security-control-panels-c-36_102/control-panels-all-c-36_102_41/castle-care-tech-euro12-control-panel-p-1720.html

 

I cant afford the new style

https://www.securitywarehouse.co.uk/catalog/intruder-alarm-c-36/security-control-panels-c-36_102/control-panels-all-c-36_102_41/castle-care-tech-contempory-lcd-keypad-with-built-in-prox-p-1615.html

The one that failed is the same but mine says "banham" instead of "tag"

Share this post


Link to post
Share on other sites
3 minutes ago, al-yeti said:

But i dont have a ebay account. I might have to become DataDiffusion 

Share this post


Link to post
Share on other sites
1 hour ago, Logan said:

But i dont have a ebay account. I might have to become DataDiffusion 

Thought your mum can bid

Share this post


Link to post
Share on other sites
11 minutes ago, al-yeti said:

Thought your mum can bid

Im buying it. Hopefully i win it

Share this post


Link to post
Share on other sites

a refurbished eur 21 brick keypad is £41+vat....

 

have you default your keypad ?

 

is the correct no. of keypad programmed into the panel ?


Mr:)

Share this post


Link to post
Share on other sites
2 hours ago, MrHappy said:

a refurbished eur 21 brick keypad is £41+vat....

 

have you default your keypad ?

 

is the correct no. of keypad programmed into the panel ?

Yes. Still cant afford the £41 replacement. I probably go using al-yetis way.  

 

Also your website doesn't work 

Screenshot_20191106-163347.png

Share this post


Link to post
Share on other sites

Lol

  • Upvote 1

Nothing is foolproof to a sufficiently talented fool.


Share this post


Link to post
Share on other sites

Logan, have you tried it with just one keypad at a time? (address that keypad as 00)

It seems strange both keypads are not working (I know it can happen)

 

Have you fully defaulted the panel?

Share this post


Link to post
Share on other sites
10 hours ago, aissecur said:

Logan, have you tried it with just one keypad at a time? (address that keypad as 00)

It seems strange both keypads are not working (I know it can happen)

 

Have you fully defaulted the panel?

The keypad addressed 00 works fine the keypad addressed 01 doesn't work 

Share this post


Link to post
Share on other sites
32 minutes ago, james.wilson said:

Have you tried reprogramming the keypad to 2 and the same in the panel?? 

Still nothing    i currently have it unregistered from the system  to remove the fault.  but still have it powered (has a blank screen)

 

Do you know where to get a castle caretech engineer keypad?

Edited by Logan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.