Jump to content
Security Installer Community
bennynoneck

Bell box tamper message

Recommended Posts

Hi. Every so often I get the above message on my risco gt 600.

 

Is there a way to temporarily stop it from blaring out? Even in engineer mode it still goes off internally and externally. 

 

It also chirps for a second every so often without giving a message which I assume is telling me the back up battery needs replacing?? 

 

I know it needs to be seen to but don't want to spend any money on it as willbr getting a new one soon.

 

Hopefully there might be a setting? Or just disconnect the cable from the control unit??? 

 

 

Ta. 

Share this post


Link to post
Share on other sites

Only way is to replace it.
Personally I would upgrade the external siren approx every 10 years otherwise you may get problems like this. A new external siren suggests you also have the latest intruder system to any would be burglar.

 I wouldn’t expect a security light to last 10 years or any other external electrical equipment.

Edited by Amps

Share this post


Link to post
Share on other sites

Lovely thanks that's really helpful. 

 

But in the meantime is there anyway to shut it up??!!  I've left the unit with the message showing in the hope it doesn't do anything again but obviously I can't arm it now. 

 

It's an old texecomm unit up there. If I was to get a wired odyssey one from texecomm should it be compatable?? The last one I did was super bright even in the day unlike this one. If so I'll order at lunch!!!! 

 

Thanks again for the heads up. 

Share this post


Link to post
Share on other sites

If the external siren tamper switch has a intermittent fault the only way to disable it is by getting the ladders up to it. 

Until you get a replacement I would disconnect the siren from the panel. It should sound for 15-20 minutes then stop. In the panel link from 0v to the tamper return terminal(TR). System should then be minus it’s external siren but fault free. 

Share this post


Link to post
Share on other sites

Sounds like the tamper switch has gone faulty in the bell.

I think you need to consider bringing this new system forward if you can.

You will most likely end up disconnecting it from the panel and breaking it off the wall.

Just disconnecting it from the panel will trigger it, best case 15 minutes of sounding worse case until the battery dies.

Share this post


Link to post
Share on other sites

This sounds very typical of the Risco nova 2 bells.... I recall a number of years ago there was a batch of them,  the piezo would chirp in extreme temperatures (usually the cold), there was a fix but I would suggest you swap the bell.

Share this post


Link to post
Share on other sites

Okay so tonight it set off again and wouldnt turn off at all so ran to the control unit and took the cover off. 

 

So for the bell cable there are wires connected to:

 

Strobe - 

Bell +

Bell - 

Bell hold

Sab tmp

 

In my panic I cut the bell +. 

 

It stopped straight away. 

 

Is that okay? Or should I just remove all the bell wires? 

 

I'm okay with an error message on the rkp but I just don't want the internal sounder to go. 

 

Can see why you guys earn your money now when things go wrong! 

Share this post


Link to post
Share on other sites

Or I guess as now it's useless I can just remove the fuse from the fcu next to it? Just don't want that sodding thing going off. 

 

I assune the batteries must have been dead in the bell box? 

Share this post


Link to post
Share on other sites
21 minutes ago, bennynoneck said:

Or I guess as now it's useless I can just remove the fuse from the fcu next to it? Just don't want that sodding thing going off. 

 

I assune the batteries must have been dead in the bell box? 

Yes dead battery killed proper , you need new bell to start with 

Share this post


Link to post
Share on other sites

New everything. I never liked it! 

Interestingly enough though over the last few nights the blox started flashing bright blue even tho the leds were green. Obviously warning me of the impending noise /failure! 

Share this post


Link to post
Share on other sites

Can you post a pic of the external bell? I can confirm its a Nova 2

Share this post


Link to post
Share on other sites
On 27/10/2019 at 14:48, bennynoneck said:

Lovely ta. I'll show it the lump hammer soon! 

Can i have it?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.