Jump to content
Security Installer Community

Recommended Posts

Hi,

 

I've managed to set it up in so far as I can access the alarm through the iphone app whilst in the house.

 

However, I'm stuck when trying to do a test call from the keypad. It just sits there saying things like "com300 idle", "resetting", etc. I've configured port forwarding, push notifications, etc, and have checked everything many times.

 

However...

 

The small instruction pamphlet that came with the ComWifi doesn't say anything about having to use a dynaminc DNS service, but I've just noticed that the main instructions that come with the panel does have a little section on it.

 

My ISP, talktalk, uses dynaminc IP adresses. Is this going to be the reason I can't send a test call (even when I'm in the house???)? Any help would be appreciated.

 

Agh!!!!!

Link to post
Share on other sites

These require good knowledge of IT and Premier Panels to setup.

Sounds like you have the panel or ComWifi incorrectly programmed.

 

Best I can offer is start again and follow the manual for the ComWifi word for word, reading several times before starting.

 

External Dynamic or Fixed IP will not matter if setup correctly.

Link to post
Share on other sites

if you can use the app on the iphone, then the unit is working, most likely on the internal ip address and your connected to your wireless router.

 

If you cant access externally on another wireless network or mobile data connection then your port forwarding isn't right or your dynamic ip has changed or you have an internal ip address assigned in your app.

 

if your notifications are working then this wouldn't be an issue as the app gets updated with the latest ip address when it polls in to the Texecom server. The app set for update ip when you open  the connection for that system the ip updates  if its selected on the app.

 

not being able to do a test call suggest that the panel isnt programmed correctly to send out the notifications.

 

however you need to know a little about what your doing with the panel and routers, version 3 elite panels would require a little more work.

Link to post
Share on other sites

Many thanks for your responses.

 

It is indeed a v3 panel. I need to use a dynamic DNS so will do that first and see if it clears up the issue. The only nagging doubt is that I thought the test call would have gone a bit further than just saying the com unit is resetting or idle.

 

I have gone through the instructions numerous times and have done everything they’ve said (well, maybe not!), so if the dynamic IP doesn’t help I would appreciate a bit more help if that’s okay, as otherwise it’ll be another hour in front of the bleeding keypad checking over the instructions!? I guess I’ll write out all the options picked on the panel and post them.

 

I’ve set up port forwarding on my router, I’ve enabled push notifications with Texecom (I have my account number), I’ve set up the router and the comwifi to work together, I’ve set up the app, everything.

 

I’ll keep you posted. I really want to make this work!

 

Thanks again, much appreciated.

Link to post
Share on other sites

You don't need a dns, as the notifications send the ip out the app then updates with the lasts ip just like the dns would.(not quite the same process).

 

if you have set things up according to the manual, whilst I am sure I could sort this out for your remotely, I need to know what's what as it is now and I don't want to offend you but need to see it.

 

If you want to discuss give us a call by all means and see what I can do

Link to post
Share on other sites

Thanks for replies.

 

It's interesting what you say about not requiring DDNS, and the arguments sound valid. I was just going on what the manual said on the installation CD, which I put below in italic. Maybe they are out of date?

 

It must be set up wrong because of this test call failure despite the app working locally. Thanks for the offer of helping but i don't want to take up your time too much. Is there anything you could suggest that might be a problem that i could look into further? What should be the IP address in the app? At the moment it's the static IP address given to it via the router (192.168.1.9).

 

UDL/digi options / Setup modules / Setup IP data:

     CommIP address - the same what's in the app, as above.

     ComIP port - 10001

     Com IP gateway - the local router IP address (the one you type in the browser to access the router)

     ComIP netmask - as assigned by the comwifi

 

UDL/digi options / program digi  

    I picked ARC1 and made it Contact ID. Just guessed these, no idea what it means!

    primary tel: 54.88.92.200/10001

    second tel: 52.28.12.230/10001

    account - the 6 digit one given to me by texecom and what's in the app.

    dial attempts - 2

    Areas - A (i only use one area)

     Reporting options (Connect via IP = ON)

 

Global options / system timers / poll every = 015

 

Digi options = Digi is enabled as is Dial all numbers

 

Comport setup / com port 1 = COM IP module

 

Does this help any?? Thanks in advance........

 

 

 

 

Remote Connections (WAN)

Before attempting to connect to the system from a remote location, please read the section on Port Forwarding, this will need to be done to allow access from outside of the LAN.

 

Fixed IP address (Uncommon)

If you have a fixed IP address internet connection, complete all of the details above, BUT replace the Host Address with the Fixed IP address provided by the Internet Service Provider.

 

Dynamic IP Address (most common)

It is most likely that you have a Dynamic IP address assigned by the service provider. This basically allows the Local system to connect to the outside world (Internet WAN), and can change frequently. Because of the nature of Dynamic addresses you will need a third party service to manage the IP address to ensure you can always connect to the system. 

 

You should search for a Dynamic DNS service provider, who may or may not charge a fee for the service. Once you have the service the Host Address will be replaced by the details given to you by the DDNS provider.
 

Link to post
Share on other sites

currently it appears you have an internal ip address and not an external one.

 

Once the notifications are setup and you have the app to update ip, it will take care of itself.

 

Just need to make sure you have the panel setup correctly

 

should be sia and not contact id, send sia text selected.

 

if version 3 then also need protocol options 2 set to the same comport the com ip unit is on (com1)

Link to post
Share on other sites

Thanks very much!

I have changed arc 1 protocol to sia level 2, changed config1 to send sia text, and config2 to use comport 1.

It now says ip connecting and ip sending....then resetting then com300 is idle. Damn! I thought we had it then!

Any ideas??

What should happen next? Should I get an email? I haven't put any mobile number in.

Link to post
Share on other sites

Hi,

 

Update - I can connect to the panel from my app remotely now, which is brilliant and many thanks! This morning I couldn't connect "locally" anymore via the app(!), but we'll see later tonight if that's resolved itself.

 

However, my wife now tells me that the system has bleeped at points throughout the day. I've logged on and it's due to a "Com 1 fault" system alert. I figure that means it's dropping connection, correct?

 

If so, would someone be so kind as to tell me how to turn this alert off? If it drops connection overnight, it's going to really annoy me.

 

I assume it wouldn't bleep indefinitely? but still, it would be annoying.

 

Many thanks (again!).

Link to post
Share on other sites

I'd love to know! I turned the router off for 10 mins but that didn't make it fail.

All done via the keypad.

You will just have to wait until the new firmware is released from Texecom.

You are not the only one to experience the problems but don't worry Texecom will get it sorted.

If you turn off push notifications for now you can still fully use the app locally & remotely and the 'system alert' will stop.

Is your router the talk talk supplied unit? Not that it should matter.

Link to post
Share on other sites

Comwifi is not reliable enough to have it monitored for drop outs.

Go monitor hardware and turn off ATS faults.

Or like above, turn off notifications, get a gsm com on com port 2 with virgin sim unlimited texts £5 a month. You'll still get a notification if power goes out/your router drops out.

You'll probably find Sms commands to be enough for your remote control needs too. Just a suggestion :-)

Link to post
Share on other sites

Hi,

 

Polling was set to 015, if that's what you meant, JamesWilson?? I'll check to see whether it's changed somehow later.

 

I'm wondering whether it had anything to do with logging on remotely via the app? I didn't go off any more when I got home, and like I say didn't go off when I turned the router off (D-Link, given by TalkTalk a couple of years ago).

 

Are firmware updates free? Can I do it through wifi via Wintex? I assume it won't wipe everything I've spent so long configuring?!

 

How would I go about turning off push notifications? Sorry to keep asking questions. I assume this would mean I wouldn't be notified if the alarm went off? It never notified me of the Com1 fault, both times. Can I just make it not issue a system alert (or make the system alert silent??)? I do remember reading something about this, but the thought of reading those instructions again make we want to weep!

 

cheers all.

 

Oh, one last question - with the app, when I go into arming, it doesn't list out the 3 part-arm options. It just says "house", which is the name of the area I use. I guess I could use the keypad, but just wondering if it should show them on here?

 

Ta all.

Link to post
Share on other sites
  • 6 months later...

I am an IP network engineer and I struggled to get this to work. It seems that the ComWifi will not exchange MAC address with some routers.  Mine is a SKY router and it would not work. This makes DHCP not possible. So I had to set it with a static IP address. Remember to make sure that the static addres is outside of your routers DHCP address pool or you will get a clash at some point in the future.

 

Also the dynamic update of IP address is very intermittent so the mobile phone app will often fail when trying to connect remotely. I created two sites in the app for my site. One with the local LAN IP address of the Comwifi and did not tick the Update IP box. I use this when on the local home wifi.

The other with a dynamic DNS hostname (instead of an IP address) which I use when accessing remotely. Again make sure that the Update IP box is not ticked. This works perfectly every time.

 

One thing to watch out for.

It is best to configure your comwifi via the panel rather than the web interface. The reason for this is that when your router talks to it it will screw up it's ARP cache. I am not sure why. Maybe it learns the MAC address of the wrong interface from the comwifi. This is evidenced by not being able to communicate with the comwifi when connecting to your home wifi.

 

To test this you can add a static IP Address into your local arp cache to prove that this is the issue. e.g. on a windows machine open a CMD prompt and

ping IPADDRESS

where IPADDRESS is the address of your comwifi

if you get a reponse then your comwifi is working OK. 

If you do not then you may have the MAC/ARP issue.

type:

arp -a

If you have the issue you will not see an entry with the IP address of your comwifi.

 

Then to temporarily fix/prove the issue add a static ARP cache entry you can type

arp -s IPADDRESS MACADDRESS

replace with the IP address and MAC address of your comwifi.

type arp -a again and you will see your comwifi address in the list.

You should now be able to ping it.

remove the entry from your arp cache by typing

arp -d IPADDRESS

then type arp -a to check that it is no longer listed.

ping will not work again.

 

This is not a fix! just a test to prove that the issue is with the comwifi and your local network ARP cache updates.

 

If you are confident that your Comwifi is configured correctly then you need to reset the comwifi so that your local network router can refresh it's MAC table correctly. Use the panel to remove and add the COMIP module from whatever COM port you have it assigned to. This will reset it and your router should then learn the correct MAC address and resolve it's IP address for your other devices on the wifi network.

You should be able to ping it from your command prompt.

DO NOT connect to the Comwifi local wifi network. This will screw up the ARP cache again. You will lose local connectivity and will have to do the a above procedure again..

 

Hopes this helps somebody.

Edited by delluybeanhead
Link to post
Share on other sites
On 1/20/2016 at 10:40 PM, bennynoneck said:

I'd love to know! I turned the router off for 10 mins but that didn't make it fail.

All done via the keypad.

 

The reporting time is defaulted to 15mins, so when you have first set it up it might not of registered the ip address with texecom for 15mins

www.nova-security.co.uk

www.nsiapproved.co.uk

No PMs please unless i know you or you are using this board with your proper name.

Link to post
Share on other sites
34 minutes ago, delluybeanhead said:

I am an IP network engineer and I struggled to get this to work. It seems that the ComWifi will not exchange MAC address with some routers.  Mine is a SKY router and it would not work. This makes DHCP not possible. So I had to set it with a static IP address. Remember to make sure that the static addres is outside of your routers DHCP address pool or you will get a clash at some point in the future.

 

It is advisable to use a static IP that is outside of the pool over DHCP.

 

35 minutes ago, delluybeanhead said:

Also the dynamic update of IP address is very intermittent so the mobile phone app will often fail when trying to connect remotely. I created two sites in the app for my site. One with the local LAN IP address of the Comwifi and did not tick the Update IP box. I use this when on the local home wifi.

The other with a dynamic DNS hostname (instead of an IP address) which I use when accessing remotely. Again make sure that the Update IP box is not ticked. This works perfectly every time.

 

This sounds like a server side issue that happens on occasion.

Linked into your own DDNS service or Static IP with Update IP off is best solution IMO.

 

35 minutes ago, delluybeanhead said:

IIt is best to configure your comwifi via the panel rather than the web interface.

 

There is setup required on the panel and with the web interface.

If you follow the manual word for word and you understand the terms you shouldn't go wrong.

 

41 minutes ago, delluybeanhead said:

DO NOT connect to the Comwifi local wifi network. This will screw up the ARP cache again. You will lose local connectivity and will have to do the a above procedure again..

 

 

I would switch off the COMWiFi local network while in the interface configuring it.

If you do get the ARP issues you mention above and are not sure on clearing them, you can simply reboot everything wait for connection to come back up and then continue.

Link to post
Share on other sites

had a lot of fun with these initially.

 

certainly outside the dhcp pool makes life easier,

making sure nothing can automatically connect to the com wifi ssid seems to keep it focused.

 

wrt to the app, change the polling to 1 minute and it soon updates the ip, or with notifications on send an event via the keypad and it will be updated.

the polling changes between 5 minutes(in engineering) and 15 minutes normally.

 

as for routers, I have had issues with talk talk routers not liking the app on an external network so had customers with both a local and external connection.

 

as for the notifications themselves I have a system with a comip and a GSM, gsm is only set for alarm events at the minute but find it more reliable than the app.

 

Find the Risco cloud much more reliable and instant for notifications over The Texecom App, but I digress theres good and bad in all things,

 

 

Link to post
Share on other sites
  • 1 year later...

Hi,

 

 

I know it's been a while since the last activity on this thread, however, I've stumbled upon an issue with the app. Couple of months ago I set it up as per @delluybeanhead instructions above. I created two profiles, one local and one remote. All worked fine till last couple of weeks. Now the local profile still works fine, and the remote profile keeps disconnecting. To make everything even more interesting,  notifications keep coming when off-site through the remote profile each time the alarm is armed and disarmed.

 

Has anybody else had similar experience with Texecom app? I've noticed the app hasn't been updated since iOS 9 was roaming on iDevices back in Feb 2016...and we're now far into iOS 11. Any help or suggestions what to try to get the app working remotely again would be great.

 

 

Thanks.

 

P.S.: the module is ComIP, if that makes any difference.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.