Jump to content
Security Installer Community

Texecom Premier 48 - Battery Fault


Go to solution Solved by alterEGO,

Recommended Posts

  • 5 years later...

This must be a bug like a previous post has suggested. I’ve put a brand new system in a week ago and I’ve had them call up saying it’s going off due to a battery fault. I’ve turned the battery monitoring off in the settings and will call Texecom tomorrow. This is the second one I’ve had now with this. Both had new batteries. Hopefully tech support can explain tomorrow because I’ll start to get customers thinking I’m putting in dodgey systems if it carries on 

Link to post
Share on other sites

You bumped a really old thread, the firmware was very different back then possibly even older hardware.

Not needed to do the "battery monitoring shuffle" at all on the newer hardware.

 

Are you sure these new batteries are good quality and fully charged before installing? I wouldn't be surprised if the battery was at fault and the battery test timer was 7 days.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.